Interconnection Maintenance Event – Streaming & File Delivery Services Impacted: AWS West Direct Connect Maintenance Window – August 14, 2026

Incident Report for Edisen Inc

Resolved

Interconnection Service Recipient,

AWS Direct Connect endpoint maintenance has now been concluded. Your site can switch back to your local feed via the Livestream Manager (formally the PBS LLS Admin Console) at this time. Please notify any streaming providers that the local feed has been restored, if needed.

If connectivity or task processing issues persist after the maintenance window has ended, please contact Edisen Support for assistance.

Again, we are very sorry for this longer than expected maintenance by AWS on their Direct Connect endpoint in Seattle, WA.

Orb Group Support Team:
sixtickets@edisen.com
• 1(866) 748 - 4467 Ext. 2
Posted Aug 14, 2026 - 06:31 PDT

Update

Interconnection Service Recipient,

AWS has provided the following update:

"The maintenance that was scheduled for AWS Direct Connect endpoint in Westin Building Exchange, Seattle, WA from Friday, August 14, 2026, 06:00 AM ET to August 14, 2026, 08:00 AM ET will not complete within the announced window. All work is now expected to be completed and service successfully restored by Fri, 14 Aug 2026 10:00 AM ET. "

We sincerely apologize for the inconvenience this has caused you. We will continue to provide any updates as they become available.
Posted Aug 14, 2026 - 06:03 PDT

Identified

Interconnection Service Recipients,

AWS conducting maintenance on their Direct Connect endpoint has resulted in longer than expected loss of connectivity than what was currently expected. Maintenance was supposed to end August 14, 2026, 08:00 AM ET but is still ongoing. We will update this status page once AWS has concluded their maintenance window or shared more information.

We are very sorry for this unexpected inconvenience.

Orb Team
Posted Aug 14, 2026 - 05:48 PDT
This incident affected: Interconnection Local Live Linear Streaming (Terrestrial) and Interconnection National Program Feeds (Terrestrial).