Resolved - AWS has confirmed that the earlier operational issues were due to a networking problem in the affected region and that the issue is now resolved. Orb and Interconnection services, including Linear Streaming and MagnuBox connectivity, have remained stable since recovery began, and all Orb monitoring alerts have self-resolved.
Interconnection service recipients may resume all normal workflows. For PBS Member Station Platform Streaming, if a failover to the National feed took place, your site can now switch back to your local feed via PBS LLS Admin Console. Please notify any streaming providers that the local feed has been restored, if needed.
Posted Jul 24, 2026 - 06:19 PDT
Update
Update - All services have remained stable. All Orb monitoring alerts have self-resolved, indicating that connectivity for Linear Streams and MagnuBox has been restored. We have also confirmed that all MagnuBoxes and Titan Encoders are reachable.
We have not yet received an update from AWS regarding the underlying regional issue. We will continue to monitor for signs that the root cause has been resolved.
For PBS Member Station Platform Streaming, if a failover to the National feed took place, your site can now switch back to your local feed via PBS LLS Admin Console. Please notify any streaming providers that the local feed has been restored, if needed.
Posted Jul 24, 2026 - 05:34 PDT
Monitoring
Update / Partial Restoration: Our monitoring and observability platforms indicate that connectivity for Linear Streaming and Magnubox Connectivity is being restored. We are continuing to monitor these services closely to confirm full recovery and stability across all affected systems.
We will provide another update once we have confirmed that all services are operating normally.
Posted Jul 24, 2026 - 05:07 PDT
Update
Update - At 7:40 ET, AWS communicated that they are investigating operational issues affecting the region in which Orb and Interconnection infrastructure is hosted. This aligns with the symptoms we are observing across our streaming and Interconnection services.
We are continuing to work with our partner vendors and monitoring the AWS health status to explore all available paths to resolution, regardless of whether the root cause is confirmed to be AWS-related or not. We will provide another update as soon as new information becomes available.
Posted Jul 24, 2026 - 04:56 PDT
Investigating
Interconnection Service Recipients,
Beginning at 2026-24-7 06:57hrs EDT, a high number of Interconnection Linear Feeds were interrupted. Impacted Linear Streams have been failed over to the National feed.
We are also investigating a MagnuBox Connectivity outage, which looks to be impacted for some sites.
Investigation is ongoing with all streaming partners and vendors engaged. A follow-up message will be sent when the interruption is resolved. Once the outage has resolved, stations may switch back to their local feed via the PBS LLS Admin Console if a failover to the National feed took place.
After resolution, a root cause analysis will be performed and be shared in follow-up communications.
Posted Jul 24, 2026 - 04:27 PDT
This incident affected: Interconnection Orb MagnuBox Devices (Terrestrial), Interconnection Local Live Linear Streaming (Terrestrial), and Interconnection National Program Feeds (Terrestrial).