During this window, only Secondary Devices were upgraded. Based on the upgrade results from the Secondary upgrades, the upgrade session for the Primary Devices was postponed.
When the Edisen Edge Device Upgrade process resumes, a fresh communication effort will be initiated to alert service recipients of the upgrade schedule.
Edisen Support Team
Posted Jun 18, 2025 - 13:06 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 12:01 PDT
Scheduled
On Wednesday, June 18th, from 3:00 PM - 6:00 PM ET (Noon - 3:00 PM PT), the Edisen Support Team will coordinate an Interconnection System Maintenance Window to perform a software upgrade on your Edisen Edge Device (Partial Footprint Upgrade).
Once the upgrade is applied your Edisen Edge Device will reboot. For file delivery service, any pending content requests will be unaffected. Downloads in progress will resume automatically once the reboot is complete. There should be no station intervention required, and the upgrade should conclude within 10 minutes once initiated.
There will be no impact to linear delivery service.
Interconnection Global GUI access will remain operational during this Maintenance Window.
Stations included in this upgrade session are noted below:
The Maintenance Window will be completed, and normal service should resume no later than 6:00 PM ET (3:00 PM PT).
In the event that a service disruption does occur during this window, no action is needed from Interconnection sites. The Edisen support team will reach out to you.
If a service disruption occurs after this window has closed, please contact the Edisen Support Team: